Sign in to follow this  
Cavadus

[SWG] Launcher Usage Update

1 post in this topic

kTioBXP.png

Dear Legends,

It has come to our attention that some players are circumventing the patching service on the launcher by playing with the current version number. This will leave both your game, ILM and Launcher out of date and most importantly missing critical launcher updates to fix issues that you might actually be having.

Please DO NOT instruct players to do so, if you have issues with the launcher please put in a ticket and we will do our best to try and help you get things up and running. 9 times out of 10 we can easily get you up and running as it seems to be install issues mostly. (Not being put into the correct folders etc..).

For the users that have circumvented the system. In the coming days we will be implementing ways of catching your launcher and reverting you back to our download page with no chance of diverting this until done correctly. Using the most updated version of the launcher is critical to ensure you have a smoother experience of the game and reduces the chance of any critical issues you may experience.

May the force be with you,

SWG:Legends Staff

View the full article

Share this post


Link to post
Share on other sites

Sign in to follow this